Vulnerability detail

CVE-2019-9636

緊急

Ubuntuに関する脆弱性

公開: 2019/03/09 更新: 2026/10/14

概要

Python 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.9, v3.6.9rc1; v3.7.3, v3.7.3rc1, v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.

影響を受ける製品・バージョン

製品 対象バージョン 修正版 状態
Python >= 2.7.0 / < 2.7.17 - 確認中
Python >= 3.0.0 / < 3.4.10 - 確認中
Python >= 3.5.0 / < 3.5.7 - 確認中
Python >= 3.6.0 / < 3.6.9 - 確認中
Python >= 3.7.0 / < 3.7.3 - 確認中
Ubuntu 12.04 - 確認中
Ubuntu 14.04 - 確認中
Ubuntu 16.04 - 確認中
Ubuntu 18.04 - 確認中
Ubuntu 19.04 - 確認中